$re = '/From:.+\r?\nSent:.+\r?\nTo:.+\r?\nSubject:.+/';
$str = 'From: ***********************
Sent: ***********************
To: ***********************
Subject: *******************';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);