using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"From:.+\r?\nSent:.+\r?\nTo:.+\r?\nSubject:.+";
string input = @"From: ***********************
Sent: ***********************
To: ***********************
Subject: *******************";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}