re = /From:.+\r?\nSent:.+\r?\nTo:.+\r?\nSubject:.+/
str = 'From: ***********************
Sent: ***********************
To: ***********************
Subject: *******************'
# Print the match result
str.match(re) do |match|
puts match.to_s
end