#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?:.* through |^)(.+?)(?: at |$)"
Local $sString = "Beginning through June 18, 2022 at Noon standard time\n" & @CRLF & _
"Jan 20, 2022" & @CRLF & _
"Beginning through April 26, 2022 at 12:01 a.m. standard time"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")