re = /(?:.* through |^)(.+?)(?: at |$)/m
str = 'Beginning through June 18, 2022 at Noon standard time\\n
Jan 20, 2022
Beginning through April 26, 2022 at 12:01 a.m. standard time'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end