// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(?:.* through |^)(.+?)(?: at |$)").unwrap();
let string = "Beginning through June 18, 2022 at Noon standard time\\n
Jan 20, 2022
Beginning through April 26, 2022 at 12:01 a.m. standard time";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}