$re = '/(?:.* through |^)(.+?)(?: at |$)/m';
$str = 'Beginning through June 18, 2022 at Noon standard time\\n
Jan 20, 2022
Beginning through April 26, 2022 at 12:01 a.m. standard time';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);