use strict;
my $str = 'Beginning through June 18, 2022 at Noon standard time\\n
Jan 20, 2022
Beginning through April 26, 2022 at 12:01 a.m. standard time';
my $regex = qr/(?:.* through |^)(.+?)(?: at |$)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}