using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^([^\x00-\x7F]|[\w_\ \.\+\-]){2,16}$";
string input = @"MartBuča1as_sass";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}