const regex = /^([^\x00-\x7F]|[\w_\ \.\+\-]){2,16}$/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^([^\\x00-\\x7F]|[\\w_\\ \\.\\+\\-]){2,16}$', '')
const str = `MartBuča1as_sass`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}