package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^([^\x00-\x7F]|[\w_\ \.\+\-]){2,16}$`)
var str = `MartBuča1as_sass`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}