$re = '/^([^\x00-\x7F]|[\w_\ \.\+\-]){2,16}$/';
$str = 'MartBuča1as_sass';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);