using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?<last>[^,\n\r]+), *(?<first>[^,\s]+)*(?: +(?<middle>[^,\n\r]+)+?)*(?:, *(?<suffix>[^\n]+))*.*$";
string input = @"Toner,
Toner, Ryan
Toner, Ryan,
Toner, Ryan, Jr
Toner, Ryan, Jr,
Toner, Ryan William
Toner, Ryan William,
Toner, Ryan William, III
Toner, R W
Toner, R.W.
Toner, R. W.
Toner, R. W., Jr
Von Toner, Ryan
Von-Toner, Ryan William Corey, III
Ryan William Toner
Ryan William Toner, Jr";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}