const regex = /^(?<last>[^,\n\r]+), *(?<first>[^,\s]+)*(?: +(?<middle>[^,\n\r]+)+?)*(?:, *(?<suffix>[^\n]+))*.*$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?<last>[^,\\n\\r]+), *(?<first>[^,\\s]+)*(?: +(?<middle>[^,\\n\\r]+)+?)*(?:, *(?<suffix>[^\\n]+))*.*$', 'gm')
const str = `Toner,
Toner, Ryan
Toner, Ryan,
Toner, Ryan, Jr
Toner, Ryan, Jr,
Toner, Ryan William
Toner, Ryan William,
Toner, Ryan William, III
Toner, R W
Toner, R.W.
Toner, R. W.
Toner, R. W., Jr
Von Toner, Ryan
Von-Toner, Ryan William Corey, III
Ryan William Toner
Ryan William Toner, Jr`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}