// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(?<last>[^,\n\r]+), *(?<first>[^,\s]+)*(?: +(?<middle>[^,\n\r]+)+?)*(?:, *(?<suffix>[^\n]+))*.*$").unwrap();
let string = "Toner,
Toner, Ryan
Toner, Ryan,
Toner, Ryan, Jr
Toner, Ryan, Jr,
Toner, Ryan William
Toner, Ryan William,
Toner, Ryan William, III
Toner, R W
Toner, R.W.
Toner, R. W.
Toner, R. W., Jr
Von Toner, Ryan
Von-Toner, Ryan William Corey, III
Ryan William Toner
Ryan William Toner, Jr";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}