import re
regex = re.compile(r"^(?<last>[^,\n\r]+), *(?<first>[^,\s]+)*(?: +(?<middle>[^,\n\r]+)+?)*(?:, *(?<suffix>[^\n]+))*.*$", flags=re.MULTILINE)
test_str = ("Toner,\n"
"Toner, Ryan\n"
"Toner, Ryan,\n"
"Toner, Ryan, Jr\n"
"Toner, Ryan, Jr,\n"
"Toner, Ryan William\n"
"Toner, Ryan William,\n"
"Toner, Ryan William, III\n"
"Toner, R W\n"
"Toner, R.W.\n"
"Toner, R. W.\n"
"Toner, R. W., Jr\n"
"Von Toner, Ryan\n"
"Von-Toner, Ryan William Corey, III\n"
"Ryan William Toner\n"
"Ryan William Toner, Jr")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")