$re = '/^(?<last>[^,\n\r]+), *(?<first>[^,\s]+)*(?: +(?<middle>[^,\n\r]+)+?)*(?:, *(?<suffix>[^\n]+))*.*$/m';
$str = 'Toner,
Toner, Ryan
Toner, Ryan,
Toner, Ryan, Jr
Toner, Ryan, Jr,
Toner, Ryan William
Toner, Ryan William,
Toner, Ryan William, III
Toner, R W
Toner, R.W.
Toner, R. W.
Toner, R. W., Jr
Von Toner, Ryan
Von-Toner, Ryan William Corey, III
Ryan William Toner
Ryan William Toner, Jr';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);