const regex = /[A-Za-z]/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[A-Za-z]', 'g')
const str = `aosif\$!oias832unaca818`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);