use strict;
my $str = 'aosif$!oias832unaca818';
my $regex = qr/[A-Za-z]/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";