import Foundation
let pattern = #"[A-Za-z]"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"aosif$!oias832unaca818"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)