$re = '/[A-Za-z]/';
$str = 'aosif$!oias832unaca818';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;