using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(ux|\s{2})";
string input = @"amenagement intérieur rangement james bont express plur
bertaux another word ";
RegexOptions options = RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}