const regex = /(ux|\s{2})/gi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(ux|\\s{2})', 'gi')
const str = `amenagement intérieur rangement james bont express plur
bertaux another word `;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}