package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)(ux|\s{2})`)
var str = `amenagement intérieur rangement james bont express plur
bertaux another word `
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}