re = /(ux|\s{2})/i
str = 'amenagement intérieur rangement james bont express plur
bertaux another word '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end