#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?s)<textarea>((?:(?!<\/textarea>).)*?)ccc(.*?)<\/textarea>" & @CRLF & _
""
Local $sString = "<textarea>asdasdasdasd as</textarea>" & @CRLF & _
"<textarea>asdacccda " & @CRLF & _
"sdas</textarea>" & @CRLF & _
"<textarea>asdasdasdasd as</textarea>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")