import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<textarea>((?:(?!<\\/textarea>).)*?)ccc(.*?)<\\/textarea>\n";
final String string = "<textarea>asdasdasdasd as</textarea>\n"
+ "<textarea>asdacccda \n"
+ "sdas</textarea>\n"
+ "<textarea>asdasdasdasd as</textarea>";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}