$re = '/<textarea>((?:(?!<\/textarea>).)*?)ccc(.*?)<\/textarea>
/s';
$str = '<textarea>asdasdasdasd as</textarea>
<textarea>asdacccda
sdas</textarea>
<textarea>asdasdasdasd as</textarea>';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);