re = /<textarea>((?:(?!<\/textarea>).)*?)ccc(.*?)<\/textarea>
/
str = '<textarea>asdasdasdasd as</textarea>
<textarea>asdacccda
sdas</textarea>
<textarea>asdasdasdasd as</textarea>'
# Print the match result
str.match(re) do |match|
puts match.to_s
end