using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(january|february|march|april|may|june|july|august|september|octorber|november|december) ([1-9]|[1-2]\d|3[01]), \d{4}";
string input = @"It was a fine day. September 1, 2018 and I had a lot of laughs August 2, 2017 and then again on August 23, 2017";
RegexOptions options = RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}