re = /(january|february|march|april|may|june|july|august|september|octorber|november|december) ([1-9]|[1-2]\d|3[01]), \d{4}/i
str = 'It was a fine day. September 1, 2018 and I had a lot of laughs August 2, 2017 and then again on August 23, 2017'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end