import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(january|february|march|april|may|june|july|august|september|octorber|november|december) ([1-9]|[1-2]\\d|3[01]), \\d{4}";
final String string = "It was a fine day. September 1, 2018 and I had a lot of laughs August 2, 2017 and then again on August 23, 2017";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}