const regex = new RegExp('(january|february|march|april|may|june|july|august|september|octorber|november|december) ([1-9]|[1-2]\\d|3[01]), \\d{4}', 'gi')
const str = `It was a fine day. September 1, 2018 and I had a lot of laughs August 2, 2017 and then again on August 23, 2017`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}