package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)(january|february|march|april|may|june|july|august|september|octorber|november|december) ([1-9]|[1-2]\d|3[01]), \d{4}`)
var str = `It was a fine day. September 1, 2018 and I had a lot of laughs August 2, 2017 and then again on August 23, 2017`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}