using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\W(banana|lemon|mango|pinea|200|assigned|1)";
string input = @"asdasd
a PINEAPPLE 200 20 great oaks great oaks blvd 22 11 1 2 apineapple varun nikhin
";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}