// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mi)\W(banana|lemon|mango|pinea|200|assigned|1)").unwrap();
let string = "asdasd
a PINEAPPLE 200 20 great oaks great oaks blvd 22 11 1 2 apineapple varun nikhin
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}