const regex = /\W(banana|lemon|mango|pinea|200|assigned|1)/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\W(banana|lemon|mango|pinea|200|assigned|1)', 'gmi')
const str = `asdasd
a PINEAPPLE 200 20 great oaks great oaks blvd 22 11 1 2 apineapple varun nikhin
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}