re = /\W(banana|lemon|mango|pinea|200|assigned|1)/mi
str = 'asdasd
a PINEAPPLE 200 20 great oaks great oaks blvd 22 11 1 2 apineapple varun nikhin
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end