import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:\\d+(?:\\.\\d+)?|\\.\\d+)(?:,(?:\\d+(?:\\.\\d+)?|\\.\\d+))*$";
final String string = "9.8,8.6\n"
+ "9.8\n"
+ "8.2,9\n"
+ "5,9\n"
+ "9.8,8.6,1.1\n"
+ "1,8.6\n"
+ "9.8,8.6,1.1\n"
+ "8,8,8\n"
+ "9.8,8,8\n"
+ "1,1\n"
+ "1,1,.1,1\n"
+ "5.5.5\n"
+ "3,3,3.3.3";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}