re = /^(?:\d+(?:\.\d+)?|\.\d+)(?:,(?:\d+(?:\.\d+)?|\.\d+))*$/m
str = '9.8,8.6
9.8
8.2,9
5,9
9.8,8.6,1.1
1,8.6
9.8,8.6,1.1
8,8,8
9.8,8,8
1,1
1,1,.1,1
5.5.5
3,3,3.3.3'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end