// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(?:\d+(?:\.\d+)?|\.\d+)(?:,(?:\d+(?:\.\d+)?|\.\d+))*$").unwrap();
let string = "9.8,8.6
9.8
8.2,9
5,9
9.8,8.6,1.1
1,8.6
9.8,8.6,1.1
8,8,8
9.8,8,8
1,1
1,1,.1,1
5.5.5
3,3,3.3.3";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}