const regex = /^(?:\d+(?:\.\d+)?|\.\d+)(?:,(?:\d+(?:\.\d+)?|\.\d+))*$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:\\d+(?:\\.\\d+)?|\\.\\d+)(?:,(?:\\d+(?:\\.\\d+)?|\\.\\d+))*$', 'gm')
const str = `9.8,8.6
9.8
8.2,9
5,9
9.8,8.6,1.1
1,8.6
9.8,8.6,1.1
8,8,8
9.8,8,8
1,1
1,1,.1,1
5.5.5
3,3,3.3.3`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}