use strict;
my $str = '9.8,8.6
9.8
8.2,9
5,9
9.8,8.6,1.1
1,8.6
9.8,8.6,1.1
8,8,8
9.8,8,8
1,1
1,1,.1,1
5.5.5
3,3,3.3.3';
my $regex = qr/^(?:\d+(?:\.\d+)?|\.\d+)(?:,(?:\d+(?:\.\d+)?|\.\d+))*$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}