import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[0-9]{1,3}(?:\\.[0-9]{3})*,[0-9]{2}(?![0-9])";
final String string = "Valid\n"
+ "455,80SomeText\n"
+ "1,00\n"
+ "30,82\n"
+ "7,78 SomeText\n"
+ "622,21\n"
+ "8.542,85\n\n"
+ "Invalid examples\n"
+ "455,482\n"
+ "54,1\n"
+ "7454,50\n"
+ ",42";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}