const regex = /^[0-9]{1,3}(?:\.[0-9]{3})*,[0-9]{2}(?![0-9])/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[0-9]{1,3}(?:\\.[0-9]{3})*,[0-9]{2}(?![0-9])', 'gm')
const str = `Valid
455,80SomeText
1,00
30,82
7,78 SomeText
622,21
8.542,85
Invalid examples
455,482
54,1
7454,50
,42`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}