$re = '/^[0-9]{1,3}(?:\.[0-9]{3})*,[0-9]{2}(?![0-9])/m';
$str = 'Valid
455,80SomeText
1,00
30,82
7,78 SomeText
622,21
8.542,85
Invalid examples
455,482
54,1
7454,50
,42';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);