#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[^\[\]]*(?:\[[^\[\]]*\][^\[\]]*)*[^\[\]]*$"
Local $sString = "A;BB;C[1;22];DDD[11;2;33];EEEEE[1111]" & @CRLF & _
"A;BB;C[1;22;DDD[11;2;33];EEEEE[1111]" & @CRLF & _
"A;BB;C[1;22];DDD11;2;33];EEEEE[1111]" & @CRLF & _
"A;BB;C[1;22];DDD[11;[3],2;33];EEEEE[1111]" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")