package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[^\[\]]*(?:\[[^\[\]]*\][^\[\]]*)*[^\[\]]*$`)
var str = `A;BB;C[1;22];DDD[11;2;33];EEEEE[1111]
A;BB;C[1;22;DDD[11;2;33];EEEEE[1111]
A;BB;C[1;22];DDD11;2;33];EEEEE[1111]
A;BB;C[1;22];DDD[11;[3],2;33];EEEEE[1111]
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}