import Foundation
let pattern = #"^[^\[\]]*(?:\[[^\[\]]*\][^\[\]]*)*[^\[\]]*$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
A;BB;C[1;22];DDD[11;2;33];EEEEE[1111]
A;BB;C[1;22;DDD[11;2;33];EEEEE[1111]
A;BB;C[1;22];DDD11;2;33];EEEEE[1111]
A;BB;C[1;22];DDD[11;[3],2;33];EEEEE[1111]
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)