re = /^[^\[\]]*(?:\[[^\[\]]*\][^\[\]]*)*[^\[\]]*$/m
str = 'A;BB;C[1;22];DDD[11;2;33];EEEEE[1111]
A;BB;C[1;22;DDD[11;2;33];EEEEE[1111]
A;BB;C[1;22];DDD11;2;33];EEEEE[1111]
A;BB;C[1;22];DDD[11;[3],2;33];EEEEE[1111]
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end